Pier problems

Nicolas MELIN n.melin at microkwen.com
Mon Feb 20 00:08:16 MET 2006


Hi,
this is a mail I sent on the wrong smallwiki mailing-list a few weeks  
ago.

I finally got the time to install Pier. The main goal is not to have  
a rock stable wiki (I would have used SmallWiki for that), but rather  
to test Pier.

I installed Pier from scratch, to have the latest versions. (I  
followed instructions given on http://smallwiki.unibe.ch/smallwiki/ 
pier/installationofpier/). As I needed the authentication features, I  
installed the Pier-Security too.

The versions I used are:
- Pier-Model-lr.39
- Pier-Tests-lr.22
- Pier-Seaside-lr.36
- Pier-Security-pmm.17

At the moment, I have 3 kernels running. I noted a few problems :

- Pier-Security: I added users, groups without problem. Then I  
disabled the View Command for "Other" users.
The problem is, disabling view doesn't hide contents. ie: "Other"  
users can still view the first page of the wiki (even if the links  
are grayed), the tree contents, and worst, if they type the address  
directly, they can view all the pages of the wiki. (this problem was  
already reported by Cédrick Béler, and I fixed it quick&dirty by  
modifying PRContentsWidget and PRTreeWidget to only display content  
when context isValid)

Another thing, even after fixing the first problem, when I click on  
Login, the context becomes valid, and the tree contents are displayed.


- PRFilePersistency:
	- When PRFilePersistency is instanced, it doesn't actually create  
the log file. So when using the Log or Changes commands before saving  
anything, I get a FileDoesNotExistException.

	- When a page is deleted, when I use Changes or Log Commands, I get  
an UndefinedObject error. If I manually delete the log, the problem  
is solved.

	- Would be interesting to have a way to change the default log file  
name (I added this in my image)


- mutex: I got a strange problem. Suddenly, one of the 3 kernels  
stopped accepting logins. The page just froze when I tried to login.  
I found that something went wrong with a process in this kernel's  
mutex. I tried to play with the blocked process, sending resume and  
terminate messages, but I probably shouldn't have, because the image  
locked, and the VM segfaulted, so I couldn't investigate it more  
deeply ;-)

- Do you have a bug tracker for Pier ?

Nicolas




More information about the SmallWiki mailing list