Magritte Validation Error
rleon at insario.com
Tue Nov 29 20:46:30 MET 2005
> Do you have a better suggestion on how to name it?
> I was looking for a word that does not include 'meta' as a
> substring (I think it is already used too often in different
> contexts) and that reads well and tells what it is used for.
> #description was the best thing I could find.
> In real live I only observed once having an accessor that was
> called #description and then I could change that together
> with the author to be something like #summary. I think every
> method extension sooner or later conflicts with existing software.
> Another thing, probably out-of-topic in this thread, is how
> you should call accessors, if you have an object referencing
> an external description, such as MAValidationError. I simply
> called it #description, even-tough this description does not
> describe the receiver. I probably should have called it
> #actualDescription or #targetDescription or
> #externalDescription or ... I was too lazy at the moment.
> However this problem stays the same, even if I replace the
> #description-prefix with any other.
Honestly, maybe it's a culture difference, but damned if I don't have a
description accessor on tons of my domain objects, summary doesn't feel
right to me. I was just thinking something that's less common than
description, that's just so generic a term and so common for an
accessor. Even something similar that is more behavioral sounding like
descriptor, or, really, a conversion method like asDescrition or
asDescriptor rather than just description. It's not really an accessor
anyhow, it's building a description of the object and returning it as a
container, so a conversion method seems reasonable. Thoughts?
More information about the SmallWiki